summaryrefslogtreecommitdiffstats
path: root/recipes/images/maemo-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/maemo-image.bb')
-rw-r--r--recipes/images/maemo-image.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/images/maemo-image.bb b/recipes/images/maemo-image.bb
new file mode 100644
index 0000000000..c0498bb910
--- /dev/null
+++ b/recipes/images/maemo-image.bb
@@ -0,0 +1,20 @@
+#
+# Meta package for maemo based system image
+#
+
+GUI_MACHINE_CLASS ?= "none"
+
+MAEMO_EXTRA_DEPENDS = "scap dosfstools"
+MAEMO_EXTRA_INSTALL = "osso-af-services osso-af-base-apps scap dosfstools"
+
+XSERVER ?= "xserver-kdrive-omap"
+
+DEPENDS = "${MACHINE_TASK_PROVIDER} \
+ meta-maemo \
+ ${MAEMO_EXTRA_DEPENDS}"
+
+IMAGE_INSTALL = "${MACHINE_TASK_PROVIDER} maemo-task-base maemo-task-theme \
+ maemo-task-apps ${MAEMO_EXTRA_INSTALL} \
+ ${XSERVER}"
+
+inherit image