aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images/shr-image.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images/shr-image.bb')
-rw-r--r--recipes/images/shr-image.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/images/shr-image.bb b/recipes/images/shr-image.bb
new file mode 100644
index 0000000000..e889f2dfb9
--- /dev/null
+++ b/recipes/images/shr-image.bb
@@ -0,0 +1,30 @@
+require shr-image.inc
+
+IMAGE_BASENAME = "full"
+
+DEPENDS += "task-shr"
+RDEPENDS += "\
+ task-shr-apps \
+ task-shr-games \
+ task-shr-gtk \
+"
+
+IMAGE_INSTALL += "\
+ task-shr-apps \
+ task-shr-games \
+ task-shr-gtk \
+"
+
+# perform some SHR convenience tweaks to the rootfs
+shr_rootfs_postprocess_append() {
+ curdir=$PWD
+ cd ${IMAGE_ROOTFS}
+
+
+ #Replace desktop files
+ echo "Icon=pidgin.png" >> ./usr/share/applications/pidgin.desktop
+ sed -i "s/^X-Icon-path.*$//g" ./usr/share/applications/vagalume.desktop
+
+ cd $curdir
+}
+