aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images')
-rw-r--r--recipes/images/gpe-image.bb18
1 files changed, 14 insertions, 4 deletions
diff --git a/recipes/images/gpe-image.bb b/recipes/images/gpe-image.bb
index 8cbe8a8571..57e7f7fdd6 100644
--- a/recipes/images/gpe-image.bb
+++ b/recipes/images/gpe-image.bb
@@ -1,10 +1,19 @@
+# Set some defaults
+
+MACHINE_TASK_PROVIDER = "task-base-extended"
+GUI_MACHINE_CLASS ?= "none"
+XSERVER ?= "xserver-kdrive-fbdev"
GPE_EXTRA_THEMES = "gpe-theme-industrial"
+# Select bootsplash
+SPLASH ?= ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-angstrom", "",d)}'
+
+# Select some useful things depending on the device capabilities
+
GPE_EXTRA_INSTALL_none = ""
GPE_EXTRA_INSTALL_bigscreen = "task-gpe-games ${GPE_EXTRA_THEMES}"
GPE_EXTRA_INSTALL_smallscreen = "task-gpe-games ${GPE_EXTRA_THEMES}"
-GUI_MACHINE_CLASS ?= "none"
GPE_EXTRA_INSTALL += "${GPE_EXTRA_INSTALL_${GUI_MACHINE_CLASS}}"
#ship more stuff with devices with >16MB of flash
@@ -16,10 +25,10 @@ GPE_BIGFLASH_INSTALL := '${@base_conditional("ROOT_FLASH_SIZE", "16", "", "\
GPE_EXTRA_INSTALL += "${GPE_BIGFLASH_INSTALL}"
-XSERVER ?= "xserver-kdrive-fbdev"
DEPENDS = "${MACHINE_TASK_PROVIDER} \
- task-gpe-base \
+ ${SPLASH} \
+ task-gpe-base \
task-gpe-apps \
task-gpe-pim \
task-gpe-settings \
@@ -33,8 +42,9 @@ IMAGE_INSTALL = "\
task-gpe-settings \
task-gpe-apps \
${XSERVER} \
+ ${SPLASH} \
${GPE_EXTRA_INSTALL}"
-#ROOTFS_POSTPROCESS_COMMAND += "zap_root_password; "
+ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
inherit image