aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images')
-rw-r--r--recipes/images/initramfs-kexecboot-image.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/images/initramfs-kexecboot-image.bb b/recipes/images/initramfs-kexecboot-image.bb
new file mode 100644
index 0000000000..c251aa9cf2
--- /dev/null
+++ b/recipes/images/initramfs-kexecboot-image.bb
@@ -0,0 +1,24 @@
+# Initramfs image providing kexecboot
+# a linux as bootloader implementation
+PR = "r3"
+
+ONLINE_PACKAGE_MANAGEMENT = "none"
+IMAGE_FSTYPES = "cpio.gz cpio.lzma"
+DEPENDS = "lzma-native"
+
+export IMAGE_BASENAME = "initramfs-kexecboot-image"
+
+# avoid circular dependencies
+EXTRA_IMAGEDEPENDS = ""
+
+IMAGE_INSTALL = "kexecboot"
+
+IMAGE_LINGUAS = ""
+IMAGE_LOGIN_MANAGER = ""
+IMAGE_INIT_MANAGER = ""
+IMAGE_INITSCRIPTS = ""
+IMAGE_DEV_MANAGER = ""
+
+FEED_DEPLOYDIR_BASE_URI = ""
+
+inherit image