aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/images
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/images')
-rw-r--r--recipes/images/angstrom-console-base-image.bb10
-rw-r--r--recipes/images/console-base-image.bb9
2 files changed, 16 insertions, 3 deletions
diff --git a/recipes/images/angstrom-console-base-image.bb b/recipes/images/angstrom-console-base-image.bb
new file mode 100644
index 0000000000..2fdeecb351
--- /dev/null
+++ b/recipes/images/angstrom-console-base-image.bb
@@ -0,0 +1,10 @@
+require console-base-image.bb
+
+#Angstrom bootstrap image
+ANGSTROM_EXTRA_INSTALL ?= ""
+
+IMAGE_INSTALL = "task-base \
+ ${ANGSTROM_EXTRA_INSTALL} \
+ ${SPLASH} \
+ ${ZZAPSPLASH} \
+ "
diff --git a/recipes/images/console-base-image.bb b/recipes/images/console-base-image.bb
index 9bd50316b5..2999d1c9c6 100644
--- a/recipes/images/console-base-image.bb
+++ b/recipes/images/console-base-image.bb
@@ -1,8 +1,11 @@
-#Angstrom bootstrap image
+# bootstrap image
+#
+# the Angstrom-specific bits that were originally part of this image
+# definition have been moved to angstrom-console-base-image.bb
IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
-ANGSTROM_EXTRA_INSTALL ?= ""
+IMAGE_EXTRA_INSTALL ?= ""
ZZAPSPLASH = ' ${@base_contains("MACHINE_FEATURES", "screen", "psplash-zap", "",d)}'
@@ -12,7 +15,7 @@ DEPENDS = "task-base \
"
IMAGE_INSTALL = "task-base \
- ${ANGSTROM_EXTRA_INSTALL} \
+ ${IMAGE_EXTRA_INSTALL} \
${SPLASH} \
${ZZAPSPLASH} \
"