aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/initrdscripts/initramfs-module-nfs_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/initrdscripts/initramfs-module-nfs_1.0.bb')
-rw-r--r--recipes/initrdscripts/initramfs-module-nfs_1.0.bb13
1 files changed, 13 insertions, 0 deletions
diff --git a/recipes/initrdscripts/initramfs-module-nfs_1.0.bb b/recipes/initrdscripts/initramfs-module-nfs_1.0.bb
new file mode 100644
index 0000000000..77c38799f3
--- /dev/null
+++ b/recipes/initrdscripts/initramfs-module-nfs_1.0.bb
@@ -0,0 +1,13 @@
+SRC_URI = "file://80-nfsboot.sh"
+PR = "r2"
+DESCRIPTION = "An initramfs module for booting via NFS."
+RDEPENDS = "initramfs-uniboot"
+RRECOMMENDS = "kernel-module-g-ether kernel-module-nfs"
+
+do_install() {
+ install -d ${D}/initrd.d
+ install -m 0755 ${WORKDIR}/80-nfsboot.sh ${D}/initrd.d/
+}
+
+PACKAGE_ARCH = "all"
+FILES_${PN} += " /initrd.d/* "