aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/initrdscripts
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/initrdscripts')
-rw-r--r--recipes/initrdscripts/initramfs-jffs2_0.1.bb2
-rw-r--r--recipes/initrdscripts/initramfs-module-aufs_1.0.bb2
-rw-r--r--recipes/initrdscripts/initramfs-module-block_1.0.bb2
-rw-r--r--recipes/initrdscripts/initramfs-module-bootldr-buster_1.0.bb2
-rw-r--r--recipes/initrdscripts/initramfs-module-bootmenu_1.0.bb4
-rw-r--r--recipes/initrdscripts/initramfs-module-check-modules_1.0.bb2
-rw-r--r--recipes/initrdscripts/initramfs-module-ext3_1.0.bb2
-rw-r--r--recipes/initrdscripts/initramfs-module-initfs_1.0.bb4
-rw-r--r--recipes/initrdscripts/initramfs-module-kexecboot_1.0.bb2
-rw-r--r--recipes/initrdscripts/initramfs-module-loop_1.0.bb4
-rw-r--r--recipes/initrdscripts/initramfs-module-nfs_1.0.bb4
-rw-r--r--recipes/initrdscripts/initramfs-module-psplash_1.0.bb2
-rw-r--r--recipes/initrdscripts/initramfs-module-squashfs_1.0.bb2
-rw-r--r--recipes/initrdscripts/initramfs-uniboot_1.0.bb2
14 files changed, 18 insertions, 18 deletions
diff --git a/recipes/initrdscripts/initramfs-jffs2_0.1.bb b/recipes/initrdscripts/initramfs-jffs2_0.1.bb
index 812e612126..cbb476f431 100644
--- a/recipes/initrdscripts/initramfs-jffs2_0.1.bb
+++ b/recipes/initrdscripts/initramfs-jffs2_0.1.bb
@@ -1,6 +1,6 @@
SRC_URI = "file://jffs2boot.sh"
PR = "r3"
-RRECOMMENDS = "kernel-module-mtdblock kernel-module-mtdram"
+RRECOMMENDS_${PN} = "kernel-module-mtdblock kernel-module-mtdram"
do_install() {
install -m 0755 ${WORKDIR}/jffs2boot.sh ${D}/init
diff --git a/recipes/initrdscripts/initramfs-module-aufs_1.0.bb b/recipes/initrdscripts/initramfs-module-aufs_1.0.bb
index aa31ceee36..1b8721b6ef 100644
--- a/recipes/initrdscripts/initramfs-module-aufs_1.0.bb
+++ b/recipes/initrdscripts/initramfs-module-aufs_1.0.bb
@@ -1,7 +1,7 @@
SRC_URI = "file://98-aufs.sh"
PR = "r1"
DESCRIPTION = "An initramfs module for mount aufs."
-RDEPENDS = "initramfs-uniboot aufs"
+RDEPENDS_${PN} = "initramfs-uniboot aufs"
do_install() {
install -d ${D}/initrd.d
diff --git a/recipes/initrdscripts/initramfs-module-block_1.0.bb b/recipes/initrdscripts/initramfs-module-block_1.0.bb
index b4b2d43150..f715eae2dd 100644
--- a/recipes/initrdscripts/initramfs-module-block_1.0.bb
+++ b/recipes/initrdscripts/initramfs-module-block_1.0.bb
@@ -1,6 +1,6 @@
SRC_URI = "file://85-blockboot.sh"
PR = "r3"
-RDEPENDS = "initramfs-uniboot"
+RDEPENDS_${PN} = "initramfs-uniboot"
DESCRIPTION = "An initramfs module for booting off normal block devices."
do_install() {
diff --git a/recipes/initrdscripts/initramfs-module-bootldr-buster_1.0.bb b/recipes/initrdscripts/initramfs-module-bootldr-buster_1.0.bb
index 8c4c2f7e93..f33ecd34f3 100644
--- a/recipes/initrdscripts/initramfs-module-bootldr-buster_1.0.bb
+++ b/recipes/initrdscripts/initramfs-module-bootldr-buster_1.0.bb
@@ -1,7 +1,7 @@
SRC_URI = "file://01-bootldr-buster.sh"
PR = "r2"
DESCRIPTION = "An initramfs module for ignoring bogus kernel commandline from Compaq bootldr"
-RDEPENDS = "initramfs-uniboot"
+RDEPENDS_${PN} = "initramfs-uniboot"
do_install() {
install -d ${D}/initrd.d
diff --git a/recipes/initrdscripts/initramfs-module-bootmenu_1.0.bb b/recipes/initrdscripts/initramfs-module-bootmenu_1.0.bb
index f4fd3beee2..50f9519c2a 100644
--- a/recipes/initrdscripts/initramfs-module-bootmenu_1.0.bb
+++ b/recipes/initrdscripts/initramfs-module-bootmenu_1.0.bb
@@ -1,9 +1,9 @@
SRC_URI = "file://30-bootmenu.sh"
PR = "r18"
DESCRIPTION = "An initramfs module with UI for selection of boot device."
-RDEPENDS = "klibc-utils-static-fstype initramfs-uniboot initramfs-module-block initramfs-module-loop initramfs-module-nfs"
+RDEPENDS_${PN} = "klibc-utils-static-fstype initramfs-uniboot initramfs-module-block initramfs-module-loop initramfs-module-nfs"
# For VFAT mounting.
-RRECOMMENDS = "kernel-module-nls-cp437 kernel-module-nls-iso8859-1"
+RRECOMMENDS_${PN} = "kernel-module-nls-cp437 kernel-module-nls-iso8859-1"
do_install() {
install -d ${D}/initrd.d
diff --git a/recipes/initrdscripts/initramfs-module-check-modules_1.0.bb b/recipes/initrdscripts/initramfs-module-check-modules_1.0.bb
index 6986316a6f..e1eeb6f23d 100644
--- a/recipes/initrdscripts/initramfs-module-check-modules_1.0.bb
+++ b/recipes/initrdscripts/initramfs-module-check-modules_1.0.bb
@@ -1,7 +1,7 @@
SRC_URI = "file://90-check-modules.sh"
PR = "r0"
DESCRIPTION = "An initramfs module for checking that kernel modules exist in rootfs"
-RDEPENDS = "initramfs-uniboot"
+RDEPENDS_${PN} = "initramfs-uniboot"
do_install() {
install -d ${D}/initrd.d
diff --git a/recipes/initrdscripts/initramfs-module-ext3_1.0.bb b/recipes/initrdscripts/initramfs-module-ext3_1.0.bb
index e95dcdc2ed..ad483c47f8 100644
--- a/recipes/initrdscripts/initramfs-module-ext3_1.0.bb
+++ b/recipes/initrdscripts/initramfs-module-ext3_1.0.bb
@@ -1,7 +1,7 @@
SRC_URI = "file://80-ext3.sh"
PR = "r1"
DESCRIPTION = "An initramfs module for mount ext3."
-RDEPENDS = "initramfs-uniboot"
+RDEPENDS_${PN} = "initramfs-uniboot"
do_install() {
install -d ${D}/initrd.d
diff --git a/recipes/initrdscripts/initramfs-module-initfs_1.0.bb b/recipes/initrdscripts/initramfs-module-initfs_1.0.bb
index 2c2ec07bf5..a7ca82bdff 100644
--- a/recipes/initrdscripts/initramfs-module-initfs_1.0.bb
+++ b/recipes/initrdscripts/initramfs-module-initfs_1.0.bb
@@ -1,8 +1,8 @@
SRC_URI = "file://10-initfs.sh"
PR = "r4"
DESCRIPTION = "An initramfs module for initializing filesystems."
-RDEPENDS = "initramfs-uniboot"
-RRECOMMENDS = "kernel-module-vfat kernel-module-ext2"
+RDEPENDS_${PN} = "initramfs-uniboot"
+RRECOMMENDS_${PN} = "kernel-module-vfat kernel-module-ext2"
do_install() {
install -d ${D}/initrd.d
diff --git a/recipes/initrdscripts/initramfs-module-kexecboot_1.0.bb b/recipes/initrdscripts/initramfs-module-kexecboot_1.0.bb
index 7f1e7cd5f9..585ea9a2c8 100644
--- a/recipes/initrdscripts/initramfs-module-kexecboot_1.0.bb
+++ b/recipes/initrdscripts/initramfs-module-kexecboot_1.0.bb
@@ -1,7 +1,7 @@
SRC_URI = "file://87-kexecboot.sh"
PR = "r2"
DESCRIPTION = "An initramfs module for kexecing kernel from rootfs."
-RDEPENDS = "initramfs-uniboot kexec-klibc-static"
+RDEPENDS_${PN} = "initramfs-uniboot kexec-klibc-static"
do_install() {
install -d ${D}/initrd.d
diff --git a/recipes/initrdscripts/initramfs-module-loop_1.0.bb b/recipes/initrdscripts/initramfs-module-loop_1.0.bb
index 1a2d0a9754..5d10bd3f79 100644
--- a/recipes/initrdscripts/initramfs-module-loop_1.0.bb
+++ b/recipes/initrdscripts/initramfs-module-loop_1.0.bb
@@ -2,8 +2,8 @@ SRC_URI = "file://80-loopboot.sh"
PR = "r2"
DESCRIPTION = "An initramfs module for booting a filesystem image by loopback \
mounting it."
-RDEPENDS = "initramfs-uniboot initramfs-module-initfs"
-RRECOMMENDS = "kernel-module-loop kernel-module-vfat"
+RDEPENDS_${PN} = "initramfs-uniboot initramfs-module-initfs"
+RRECOMMENDS_${PN} = "kernel-module-loop kernel-module-vfat"
do_install() {
install -d ${D}/initrd.d
diff --git a/recipes/initrdscripts/initramfs-module-nfs_1.0.bb b/recipes/initrdscripts/initramfs-module-nfs_1.0.bb
index 77c38799f3..0c303cbeb8 100644
--- a/recipes/initrdscripts/initramfs-module-nfs_1.0.bb
+++ b/recipes/initrdscripts/initramfs-module-nfs_1.0.bb
@@ -1,8 +1,8 @@
SRC_URI = "file://80-nfsboot.sh"
PR = "r2"
DESCRIPTION = "An initramfs module for booting via NFS."
-RDEPENDS = "initramfs-uniboot"
-RRECOMMENDS = "kernel-module-g-ether kernel-module-nfs"
+RDEPENDS_${PN} = "initramfs-uniboot"
+RRECOMMENDS_${PN} = "kernel-module-g-ether kernel-module-nfs"
do_install() {
install -d ${D}/initrd.d
diff --git a/recipes/initrdscripts/initramfs-module-psplash_1.0.bb b/recipes/initrdscripts/initramfs-module-psplash_1.0.bb
index 08d1cc69c4..0a44966d7f 100644
--- a/recipes/initrdscripts/initramfs-module-psplash_1.0.bb
+++ b/recipes/initrdscripts/initramfs-module-psplash_1.0.bb
@@ -1,6 +1,6 @@
SRC_URI = "file://00-psplash.sh file://99-psplash.sh"
PR = "r5"
-RDEPENDS = "initramfs-uniboot virtual-psplash"
+RDEPENDS_${PN} = "initramfs-uniboot virtual-psplash"
DESCRIPTION = "An initramfs module to enable psplash."
do_install() {
diff --git a/recipes/initrdscripts/initramfs-module-squashfs_1.0.bb b/recipes/initrdscripts/initramfs-module-squashfs_1.0.bb
index f3d50ffa49..c8e04b09d6 100644
--- a/recipes/initrdscripts/initramfs-module-squashfs_1.0.bb
+++ b/recipes/initrdscripts/initramfs-module-squashfs_1.0.bb
@@ -1,7 +1,7 @@
SRC_URI = "file://80-squashfs.sh"
PR = "r1"
DESCRIPTION = "An initramfs module for mount squashfs."
-RDEPENDS = "initramfs-uniboot"
+RDEPENDS_${PN} = "initramfs-uniboot"
do_install() {
install -d ${D}/initrd.d
diff --git a/recipes/initrdscripts/initramfs-uniboot_1.0.bb b/recipes/initrdscripts/initramfs-uniboot_1.0.bb
index fcbbdbd2cc..2ceea68001 100644
--- a/recipes/initrdscripts/initramfs-uniboot_1.0.bb
+++ b/recipes/initrdscripts/initramfs-uniboot_1.0.bb
@@ -1,7 +1,7 @@
SRC_URI = "file://init.sh"
PR = "r11"
DESCRIPTON = "A modular initramfs init script system."
-RRECOMMENDS = "kernel-module-mtdblock"
+RRECOMMENDS_${PN} = "kernel-module-mtdblock"
do_install() {
install -m 0755 ${WORKDIR}/init.sh ${D}/init