aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/install/install-native_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/install/install-native_0.1.bb')
-rw-r--r--recipes/install/install-native_0.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/recipes/install/install-native_0.1.bb b/recipes/install/install-native_0.1.bb
new file mode 100644
index 0000000000..70c027bfe1
--- /dev/null
+++ b/recipes/install/install-native_0.1.bb
@@ -0,0 +1,27 @@
+# This package uses the GNU autotools install-sh script to implement
+# a target-capable 'install' command.
+DESCRIPTION = "Target install command"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "MIT"
+INHIBIT_DEFAULT_DEPS = "1"
+PR = "r1"
+
+SRC_URI = "file://install-sh"
+
+inherit native
+
+PACKAGES = ""
+S = "${WORKDIR}"
+
+do_stage() {
+ # When the install command is executed 'STRIP' is defined correctly in
+ # the environment
+ rm -f ${STAGING_BINDIR}/install-sh
+ cp install-sh ${STAGING_BINDIR}/install-sh
+ chmod 755 ${STAGING_BINDIR}/install-sh
+ rm -f ${STAGING_BINDIR}/install
+ echo '#!/bin/sh' >${STAGING_BINDIR}/install
+ echo 'STRIPPROG="$STRIP" exec sh "${STAGING_BINDIR}/install-sh" "$@"' >>${STAGING_BINDIR}/install
+ chmod 755 ${STAGING_BINDIR}/install
+}