aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/iperf/iperf_1.7.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/iperf/iperf_1.7.0.bb')
-rw-r--r--recipes/iperf/iperf_1.7.0.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/iperf/iperf_1.7.0.bb b/recipes/iperf/iperf_1.7.0.bb
new file mode 100644
index 0000000000..1a5fec48d3
--- /dev/null
+++ b/recipes/iperf/iperf_1.7.0.bb
@@ -0,0 +1,26 @@
+SECTION = "console/network"
+DESCRIPTION = "Iperf is a tool to measure maximum TCP bandwidth, allowing the tuning of various parameters and UDP characteristics"
+HOMEPAGE = "http://dast.nlanr.net/Projects/Iperf/"
+LICENSE = "BSD"
+PR = "r1"
+
+SRC_URI = "http://dast.nlanr.net/Projects/Iperf/iperf-${PV}-source.tar.gz \
+ file://socketaddr-h-errno.diff;patch=1"
+
+inherit autotools
+
+S="${WORKDIR}/iperf-${PV}/cfg"
+
+do_configure() {
+ oe_runconf
+}
+
+do_compile() {
+ cd ${WORKDIR}/iperf-${PV}
+ oe_runmake
+}
+
+do_install() {
+ cd ${WORKDIR}/iperf-${PV}/src
+ oe_runmake INSTALL_DIR=${D}${bindir} install
+}