aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/irda-utils/irda-utils_0.9.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/irda-utils/irda-utils_0.9.15.bb')
-rw-r--r--recipes/irda-utils/irda-utils_0.9.15.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/irda-utils/irda-utils_0.9.15.bb b/recipes/irda-utils/irda-utils_0.9.15.bb
new file mode 100644
index 0000000000..1f904e58a8
--- /dev/null
+++ b/recipes/irda-utils/irda-utils_0.9.15.bb
@@ -0,0 +1,25 @@
+SECTION = "base"
+DESCRIPTION = "Provides common files needed to use IrDA. \
+IrDA allows communication over Infrared with other devices \
+such as phones and laptops."
+LICENSE = "GPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/irda/irda-utils-${PV}.tar.gz \
+ file://configure.patch;patch=1 \
+ file://m4.patch;patch=1"
+
+export SYS_INCLUDES="-I${STAGING_INCDIR}"
+BROKEN = "1"
+
+inherit autotools
+
+do_compile () {
+ oe_runmake -e -C irattach
+ oe_runmake -e -C irdaping
+}
+
+do_install () {
+ install -d ${D}${sbindir}
+ oe_runmake -C irattach ROOT="${D}" install
+ oe_runmake -C irdaping ROOT="${D}" install
+}