aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/iscsi-target/iscsi-target/Makefile.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/iscsi-target/iscsi-target/Makefile.patch')
-rw-r--r--recipes/iscsi-target/iscsi-target/Makefile.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes/iscsi-target/iscsi-target/Makefile.patch b/recipes/iscsi-target/iscsi-target/Makefile.patch
new file mode 100644
index 0000000000..3340b07240
--- /dev/null
+++ b/recipes/iscsi-target/iscsi-target/Makefile.patch
@@ -0,0 +1,26 @@
+Index: iscsitarget-1.4.20.2/Makefile
+===================================================================
+--- iscsitarget-1.4.20.2.orig/Makefile
++++ iscsitarget-1.4.20.2/Makefile
+@@ -26,11 +26,9 @@ else
+ endif
+ endif
+
+-KVER := $(shell $(CC) $(CFLAGS) -E -dM $(VERSION_FILE) | \
++KVER2 := $(shell $(CC) $(CFLAGS) -E -dM $(VERSION_FILE) | \
+ grep UTS_RELEASE | awk '{ print $$3 }' | sed 's/\"//g')
+
+-KMOD := /lib/modules/$(KVER)/extra
+-
+ KMAJ := $(shell echo $(KVER) | \
+ sed -e 's/^\([0-9][0-9]*\)\.[0-9][0-9]*\.[0-9][0-9]*.*/\1/')
+ KMIN := $(shell echo $(KVER) | \
+@@ -185,6 +183,8 @@ integ_check:
+ $(PATCHES): .patched.$(KVER)
+
+ .patched.$(KVER):
++ echo "KVER: " ${KVER}
++ echo "KREV: " ${KREV}
+ @set -e; \
+ if [ ! -e .patched.* ]; then \
+ for p in $(PATCHES); do \