aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/ixp4xx/ixp4xx-npe_2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/ixp4xx/ixp4xx-npe_2.1.bb')
-rw-r--r--recipes/ixp4xx/ixp4xx-npe_2.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/ixp4xx/ixp4xx-npe_2.1.bb b/recipes/ixp4xx/ixp4xx-npe_2.1.bb
new file mode 100644
index 0000000000..7fdc3abf63
--- /dev/null
+++ b/recipes/ixp4xx/ixp4xx-npe_2.1.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "NPE firmware for the IXP4xx line of devices"
+LICENSE = "Intel Public Licence"
+PR = "r6"
+DEPENDS = "ixp4xx-npe-native"
+
+SRC_URI = "http://www.intel.com/Please-Read-The-BB-File/IPL_ixp400NpeLibrary-2_1.zip"
+S = "${WORKDIR}/ixp400_xscale_sw/src/npeDl"
+
+COMPATIBLE_MACHINE = "(nslu2|ixp4xx)"
+
+FILES_${PN} = "${base_libdir}/firmware/NPE-B"
+
+do_compile() {
+ ${STAGING_BINDIR_NATIVE}/IxNpeMicrocode-${PV} -be
+}
+
+do_install() {
+ install -d ${D}/${base_libdir}/firmware/
+ rm ${S}/NPE-B
+ mv ${S}/NPE-B.* ${S}/NPE-B
+ install ${S}/NPE-B ${D}/${base_libdir}/firmware/
+}
+