aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jaaa/clthreads_2.4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/jaaa/clthreads_2.4.0.bb')
-rw-r--r--recipes/jaaa/clthreads_2.4.0.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/jaaa/clthreads_2.4.0.bb b/recipes/jaaa/clthreads_2.4.0.bb
new file mode 100644
index 0000000000..ac67c5028d
--- /dev/null
+++ b/recipes/jaaa/clthreads_2.4.0.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "clthreads library from http://www.kokkinizita.net/linuxaudio/"
+SECTION = "libs/multimedia"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+PR = "r0"
+
+DEPENDS = ""
+
+SRC_URI = "http://www.kokkinizita.net/linuxaudio/downloads/clthreads-${PV}.tar.bz2 \
+ file://clthreads-Makefile.patch;patch=1 \
+"
+
+S = "${WORKDIR}/clthreads-${PV}"
+
+inherit autotools pkgconfig lib_package
+
+do_stage() {
+ autotools_stage_all
+ oe_libinstall -so libclthreads ${STAGING_LIBDIR}
+ install -m 0644 clthreads.h ${STAGING_INCDIR}
+}