aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jakarta-libs/logkit_1.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/jakarta-libs/logkit_1.2.2.bb')
-rw-r--r--recipes/jakarta-libs/logkit_1.2.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/recipes/jakarta-libs/logkit_1.2.2.bb b/recipes/jakarta-libs/logkit_1.2.2.bb
new file mode 100644
index 0000000000..58d496cd08
--- /dev/null
+++ b/recipes/jakarta-libs/logkit_1.2.2.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Logging toolkit designed for secure performance orientated logging in Java applications"
+LICENSE = "AL2.0"
+AUTHOR = "Apache Software Foundation"
+
+SRC_URI = "http://www.apache.org/dist/avalon/logkit/source/${BP}-src.tar.gz"
+
+inherit java-library
+
+S = "${WORKDIR}/${BP}-dev"
+
+DEPENDS = "fastjar-native oro servlet2.3 gnumail gnujaf log4j1.2 avalon-framework-api"
+
+do_compile() {
+ mkdir -p build
+
+ oe_makeclasspath cp -s oro servlet-2.3 activation gnumail log4j-1.2 avalon-framework-api
+
+ # Built everything but the JMS and JMX classes (like in Debian)
+ javac -encoding ISO8859-1 -sourcepath src/java -cp $cp -d build \
+ `find src/java -name \*.java -and -not \( -iwholename "*jms*" -or -wholename "*test*" \)`
+
+ (cd src/java && find . -name "*.properties" -exec cp {} ../../build/{} \;)
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}