aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jcraft/jsch_0.1.40.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/jcraft/jsch_0.1.40.bb')
-rw-r--r--recipes/jcraft/jsch_0.1.40.bb12
1 files changed, 10 insertions, 2 deletions
diff --git a/recipes/jcraft/jsch_0.1.40.bb b/recipes/jcraft/jsch_0.1.40.bb
index 303195c850..c267bc0205 100644
--- a/recipes/jcraft/jsch_0.1.40.bb
+++ b/recipes/jcraft/jsch_0.1.40.bb
@@ -8,13 +8,17 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/jsch/jsch-${PV}.zip"
inherit java-library
DEPENDS = "fastjar-native jzlib"
+DEPENDS_virtclass-native = "fastjar-native jzlib-native"
+
RDEPENDS_${PN} = "libjzlib-java"
-PR = "r1"
+RDEPENDS_${PN}_virtclass-native = ""
+
+PR = "r2"
do_compile() {
mkdir -p build
- oe_makeclasspath cp -s jzlib
+ oe_makeclasspath cp -s jzlib
javac -sourcepath src -cp $cp -d build `find src -name "*.java"`
@@ -23,3 +27,7 @@ do_compile() {
SRC_URI[md5sum] = "b59cec19a487e95aed68378976b4b566"
SRC_URI[sha256sum] = "ca9d2ae08fd7a8983fb00d04f0f0c216a985218a5eb364ff9bee73870f28e097"
+
+NATIVE_INSTALL_WORKS = "1"
+BBCLASSEXTEND = "native"
+