aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/jlime/fnkey_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/jlime/fnkey_1.0.bb')
-rw-r--r--recipes/jlime/fnkey_1.0.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/jlime/fnkey_1.0.bb b/recipes/jlime/fnkey_1.0.bb
new file mode 100644
index 0000000000..fc09eeb453
--- /dev/null
+++ b/recipes/jlime/fnkey_1.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Emulates Fn key by simulating multiple keypresses."
+LICENSE = "GPLv2"
+PR = "r0"
+
+RDEPENDS = "xdotool"
+
+SRC_URI = "file://fnkey.c"
+
+do_compile() {
+ mv ${WORKDIR}/fnkey.c ${S}
+ ${CC} -o fnkey fnkey.c -I${STAGING_INCDIR} -L${STAGING_LIBDIR}
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 755 fnkey ${D}${bindir}
+}