summaryrefslogtreecommitdiffstats
path: root/recipes/jpeg
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/jpeg')
-rw-r--r--recipes/jpeg/jpeg-8b/0001-configure-make-jpeg-work-with-older-autotools.patch30
-rw-r--r--recipes/jpeg/jpeg_6b.bb5
-rw-r--r--recipes/jpeg/jpeg_8b.bb7
3 files changed, 38 insertions, 4 deletions
diff --git a/recipes/jpeg/jpeg-8b/0001-configure-make-jpeg-work-with-older-autotools.patch b/recipes/jpeg/jpeg-8b/0001-configure-make-jpeg-work-with-older-autotools.patch
new file mode 100644
index 0000000000..dd6fd52f63
--- /dev/null
+++ b/recipes/jpeg/jpeg-8b/0001-configure-make-jpeg-work-with-older-autotools.patch
@@ -0,0 +1,30 @@
+From e9e77ee999553f9b94de0288688a0bdc60b92e0f Mon Sep 17 00:00:00 2001
+From: Chase Maupin <chase.maupin@ti.com>
+Date: Tue, 17 Aug 2010 08:30:56 -0500
+Subject: [PATCH] configure: make jpeg work with older autotools
+
+* Only use the AM_SILENT_RULES variable if it is defined. Older
+ versions of automake don't support this option.
+
+Signed-off-by: Chase Maupin <chase.maupin@ti.com>
+---
+ configure.ac | 3 ++-
+ 1 files changed, 2 insertions(+), 1 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 96da13b..9a58c51 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -26,7 +26,8 @@ AM_INIT_AUTOMAKE([-Wall -Werror ansi2knr no-dist foreign])
+ # Make --enable-silent-rules the default.
+ # To get verbose build output you may configure
+ # with --disable-silent-rules or use "make V=1".
+-AM_SILENT_RULES([yes])
++# only use if available
++m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
+
+ # This is required when using the de-ANSI-fication feature.
+ AM_C_PROTOTYPES
+--
+1.7.0.4
+
diff --git a/recipes/jpeg/jpeg_6b.bb b/recipes/jpeg/jpeg_6b.bb
index 2158c6e5c0..f9a5e36f54 100644
--- a/recipes/jpeg/jpeg_6b.bb
+++ b/recipes/jpeg/jpeg_6b.bb
@@ -6,7 +6,7 @@ PRIORITY = "required"
DEPENDS = "libtool-cross"
RPROVIDES_${PN} = "jpeg"
-PR = "r9"
+PR = "r10"
#SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
SRC_URI = "ftp://aeneas.mit.edu/pub/gnu/ghostscript/jpegsrc.v${PV}.tar.gz \
@@ -19,7 +19,8 @@ S = "${WORKDIR}/jpeg-${PV}"
inherit autotools
EXTRA_OECONF="--enable-static --enable-shared"
-EXTRA_OEMAKE='"LIBTOOL=${STAGING_BINDIR_NATIVE}/${HOST_SYS}-libtool"'
+LIBTOOL = "${HOST_SYS}-libtool"
+EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
CFLAGS_append = " -D_REENTRANT"
diff --git a/recipes/jpeg/jpeg_8b.bb b/recipes/jpeg/jpeg_8b.bb
index 4251ca6538..688dcd8db9 100644
--- a/recipes/jpeg/jpeg_8b.bb
+++ b/recipes/jpeg/jpeg_8b.bb
@@ -2,12 +2,15 @@ DESCRIPTION = "libjpeg is a library for handling the JPEG (JFIF) image format."
LICENSE = "jpeg"
SECTION = "libs"
PRIORITY = "required"
-PR = "r0"
+PR = "r1"
# TODO: really needed?
RPROVIDES_${PN} = "jpeg"
-SRC_URI = "http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz"
+SRC_URI = "\
+ http://www.ijg.org/files/jpegsrc.v${PV}.tar.gz \
+ file://0001-configure-make-jpeg-work-with-older-autotools.patch \
+ "
S = "${WORKDIR}/jpeg-${PV}"
inherit autotools