aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/justreader/justreader_2.0k.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/justreader/justreader_2.0k.bb')
-rw-r--r--recipes/justreader/justreader_2.0k.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/recipes/justreader/justreader_2.0k.bb b/recipes/justreader/justreader_2.0k.bb
new file mode 100644
index 0000000000..f3f71493fc
--- /dev/null
+++ b/recipes/justreader/justreader_2.0k.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "An E-Books reader for Qt/Embedded based Palmtop Environments"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://justreader.sourceforge.net/"
+PR = "r3"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/justreader/justreader_${PV}.tgz \
+file://correct-settings-path.patch;patch=1"
+
+S = "${WORKDIR}/TextReader2"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST += 'INCLUDEPATH+="${STAGING_INCDIR}/qpe" LIBS+=-lqpe'
+export OE_QMAKE_LINK="${CXX}"
+
+do_configure_prepend() {
+ find . -name "Makefile"|xargs rm -f
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/pics/${PN}/ \
+ ${D}${palmtopdir}/apps/Applications
+ install -m 0644 apps/Applications/justreader.desktop ${D}${palmtopdir}/apps/Applications/
+ install -m 0755 bin/justreader ${D}${palmtopdir}/bin/
+ install -m 0644 pics/* ${D}${palmtopdir}/pics/justreader/
+}