aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/kexec/kexec-tools-static_1.101.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/kexec/kexec-tools-static_1.101.bb')
-rw-r--r--recipes/kexec/kexec-tools-static_1.101.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/recipes/kexec/kexec-tools-static_1.101.bb b/recipes/kexec/kexec-tools-static_1.101.bb
new file mode 100644
index 0000000000..670f055506
--- /dev/null
+++ b/recipes/kexec/kexec-tools-static_1.101.bb
@@ -0,0 +1,23 @@
+# the binaries are statical linked against klibc
+require kexec-tools.inc
+
+PR = "r4"
+DEPENDS = "klibc"
+
+SRC_URI += "file://kexec-klibc.patch;patch=1"
+S = "${WORKDIR}/kexec-tools-${PV}"
+
+EXTRA_OECONF = " --without-zlib"
+
+export CC=${TARGET_PREFIX}klcc
+
+# standart oe cflags don't work with klcc
+export CFLAGS=""
+export CPPFLAGS=""
+export LDFLAGS=""
+
+PACKAGES =+ "kexec-static kdump-static"
+
+FILES_kexec-static = "${sbindir}/kexec"
+FILES_kdump-static = "${sbindir}/kdump"
+