summaryrefslogtreecommitdiffstats
path: root/recipes/less/less_418.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/less/less_418.bb')
-rw-r--r--recipes/less/less_418.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/less/less_418.bb b/recipes/less/less_418.bb
new file mode 100644
index 0000000000..d63e2c3290
--- /dev/null
+++ b/recipes/less/less_418.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Less is a program similar to more, i.e. a terminal \
+based program for viewing text files and the output from other \
+programs. Less offers many features beyond those that more does."
+HOMEPAGE = "http://www.greenwoodsoftware.com/"
+SECTION = "console/utils"
+LICENSE = "BSD"
+DEPENDS = "ncurses"
+
+SRC_URI = "${GNU_MIRROR}/less/less-${PV}.tar.gz"
+
+inherit autotools update-alternatives
+
+do_install () {
+ oe_runmake 'bindir=${D}${bindir}' 'mandir=${D}${mandir}' install
+ mv ${D}${bindir}/less ${D}${bindir}/less.${PN}
+}
+
+ALTERNATIVE_NAME = "less"
+ALTERNATIVE_PATH = "less.${PN}"
+ALTERNATIVE_PRIORITY = "100"