aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libaal/libaal_1.0.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libaal/libaal_1.0.4.bb')
-rw-r--r--recipes/libaal/libaal_1.0.4.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/libaal/libaal_1.0.4.bb b/recipes/libaal/libaal_1.0.4.bb
new file mode 100644
index 0000000000..af847f50c6
--- /dev/null
+++ b/recipes/libaal/libaal_1.0.4.bb
@@ -0,0 +1,24 @@
+# This is the support library for reiser4progs, required when
+# building that package. The libraries from this build must
+# be installed on the system to use the reiser4progs programs
+PR = "r1"
+DESCRIPTION = "Library for user-level code accessing Reiser4 filesystems"
+HOMEPAGE = "http://www.namesys.com"
+SECTION = "base"
+LICENSE = "GPLv2"
+
+SRC_URI = "ftp://ftp.namesys.com/pub/reiser4progs/old-versions/${P}.tar.gz"
+
+inherit autotools
+
+# This disables anything which uses libminimal - that library
+# is used for boot loader stuff and so is not required unless
+# the system will boot from a Reiser4 file system, the same
+# setting must exist for the reiser4progs build
+DISABLE_LIBMINIMAL ?= "--disable-libminimal"
+EXTRA_OECONF = "${DISABLE_LIBMINIMAL}"
+
+do_stage() {
+ echo "NOTE: stage package ${PF} is: (${PN},${PV},${PR})"
+ autotools_stage_all
+}