aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libcontactsdb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libcontactsdb')
-rw-r--r--recipes/libcontactsdb/libcontactsdb_0.1.bb14
-rw-r--r--recipes/libcontactsdb/libcontactsdb_0.3.bb14
-rw-r--r--recipes/libcontactsdb/libcontactsdb_0.4.bb14
-rw-r--r--recipes/libcontactsdb/libcontactsdb_0.5.bb13
-rw-r--r--recipes/libcontactsdb/libcontactsdb_cvs.bb28
5 files changed, 83 insertions, 0 deletions
diff --git a/recipes/libcontactsdb/libcontactsdb_0.1.bb b/recipes/libcontactsdb/libcontactsdb_0.1.bb
new file mode 100644
index 0000000000..62b7566700
--- /dev/null
+++ b/recipes/libcontactsdb/libcontactsdb_0.1.bb
@@ -0,0 +1,14 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Database access library for GPE contacts"
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+DEPENDS = "libgpewidget libgpepimc sqlite"
+
+PR = "r0"
+GPE_TARBALL_SUFFIX = "bz2"
+
+inherit autotools gpe pkgconfig
+
+do_stage () {
+autotools_stage_all
+}
diff --git a/recipes/libcontactsdb/libcontactsdb_0.3.bb b/recipes/libcontactsdb/libcontactsdb_0.3.bb
new file mode 100644
index 0000000000..62b7566700
--- /dev/null
+++ b/recipes/libcontactsdb/libcontactsdb_0.3.bb
@@ -0,0 +1,14 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Database access library for GPE contacts"
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+DEPENDS = "libgpewidget libgpepimc sqlite"
+
+PR = "r0"
+GPE_TARBALL_SUFFIX = "bz2"
+
+inherit autotools gpe pkgconfig
+
+do_stage () {
+autotools_stage_all
+}
diff --git a/recipes/libcontactsdb/libcontactsdb_0.4.bb b/recipes/libcontactsdb/libcontactsdb_0.4.bb
new file mode 100644
index 0000000000..62b7566700
--- /dev/null
+++ b/recipes/libcontactsdb/libcontactsdb_0.4.bb
@@ -0,0 +1,14 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Database access library for GPE contacts"
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+DEPENDS = "libgpewidget libgpepimc sqlite"
+
+PR = "r0"
+GPE_TARBALL_SUFFIX = "bz2"
+
+inherit autotools gpe pkgconfig
+
+do_stage () {
+autotools_stage_all
+}
diff --git a/recipes/libcontactsdb/libcontactsdb_0.5.bb b/recipes/libcontactsdb/libcontactsdb_0.5.bb
new file mode 100644
index 0000000000..1bdb40ac25
--- /dev/null
+++ b/recipes/libcontactsdb/libcontactsdb_0.5.bb
@@ -0,0 +1,13 @@
+DESCRIPTION = "Database access library for GPE contacts"
+LICENSE = "LGPL"
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+DEPENDS = "libgpewidget libgpepimc sqlite"
+
+GPE_TARBALL_SUFFIX = "bz2"
+
+inherit autotools gpe pkgconfig
+
+do_stage () {
+ autotools_stage_all
+}
diff --git a/recipes/libcontactsdb/libcontactsdb_cvs.bb b/recipes/libcontactsdb/libcontactsdb_cvs.bb
new file mode 100644
index 0000000000..d11818b0bc
--- /dev/null
+++ b/recipes/libcontactsdb/libcontactsdb_cvs.bb
@@ -0,0 +1,28 @@
+LICENSE = "GPL"
+DESCRIPTION = "Database access library for GPE contacts"
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+DEPENDS = "libgpewidget libgpepimc sqlite"
+
+LICENSE = "GPL"
+
+S = "${WORKDIR}/${PN}"
+PV = "0.3+cvs${SRCDATE}"
+PR = "r1"
+
+DEFAULT_PREFERENCE = "-1"
+
+inherit autotools gpe pkgconfig
+
+SRC_URI = "${HANDHELDS_CVS};module=gpe/base/${PN}"
+
+headers = "contacts-db.h"
+
+do_stage () {
+ oe_libinstall -so libcontactsdb ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/gpe
+ for h in ${headers}; do
+ install -m 0644 ${S}/gpe/$h ${STAGING_INCDIR}/gpe/$h
+ done
+}