summaryrefslogtreecommitdiffstats
path: root/recipes/libcroco
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libcroco')
-rw-r--r--recipes/libcroco/files/croco.patch13
-rw-r--r--recipes/libcroco/libcroco_0.6.0.bb16
-rw-r--r--recipes/libcroco/libcroco_0.6.1.bb16
3 files changed, 45 insertions, 0 deletions
diff --git a/recipes/libcroco/files/croco.patch b/recipes/libcroco/files/croco.patch
new file mode 100644
index 0000000000..572f9de59f
--- /dev/null
+++ b/recipes/libcroco/files/croco.patch
@@ -0,0 +1,13 @@
+--- opie/configure.in.old 2006-05-19 20:57:30.000000000 +0100
++++ opie/configure.in 2006-05-19 20:57:56.000000000 +0100
+@@ -131,8 +131,8 @@
+ dnl Define the CROCO_LIBS and CROCO_CFLAGS variables. These will be used
+ dnl by client application to know where to find croco include files and libs.
+ dnl
+-CROCO_LIBS="-L${libdir} -lcroco-$LIBCROCO_MAJOR_VERSION.$LIBCROCO_MINOR_VERSION"
+-CROCO_CFLAGS="-I${includedir}/libcroco-$LIBCROCO_MAJOR_VERSION.$LIBCROCO_MINOR_VERSION"
++CROCO_LIBS='-L${libdir}'" -lcroco-$LIBCROCO_MAJOR_VERSION.$LIBCROCO_MINOR_VERSION"
++CROCO_CFLAGS='-I${includedir}'"/libcroco-$LIBCROCO_MAJOR_VERSION.$LIBCROCO_MINOR_VERSION"
+
+ AC_SUBST(LIBXML2_LIBS)
+ AC_SUBST(LIBXML2_CFLAGS)
diff --git a/recipes/libcroco/libcroco_0.6.0.bb b/recipes/libcroco/libcroco_0.6.0.bb
new file mode 100644
index 0000000000..ed2d303ecb
--- /dev/null
+++ b/recipes/libcroco/libcroco_0.6.0.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "The Libcroco project is an effort to build a generic Cascading Style Sheet (CSS) parsing and manipulation toolkit"
+SECTION = "x11/utils"
+DEPENDS = "glib-2.0 libxml2"
+LICENSE = "LGPL"
+PR = "r2"
+
+inherit autotools pkgconfig gnome
+
+SRC_URI_append = " file://croco.patch;patch=1 "
+
+do_stage() {
+ install -d ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/libcroco
+ install -m 644 src/*.h ${STAGING_INCDIR}/libcroco/
+ install -m 755 src/.libs/*so* ${STAGING_LIBDIR}/
+}
diff --git a/recipes/libcroco/libcroco_0.6.1.bb b/recipes/libcroco/libcroco_0.6.1.bb
new file mode 100644
index 0000000000..cc7fc05d62
--- /dev/null
+++ b/recipes/libcroco/libcroco_0.6.1.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "The Libcroco project is an effort to build a generic Cascading Style Sheet (CSS) parsing and manipulation toolkit"
+SECTION = "x11/utils"
+DEPENDS = "glib-2.0 libxml2"
+LICENSE = "LGPL"
+PR = "r2"
+
+inherit autotools pkgconfig gnome
+
+SRC_URI_append = " file://croco.patch;patch=1 "
+
+do_stage() {
+ install -d ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/libcroco
+ install -m 644 src/*.h ${STAGING_INCDIR}/libcroco/
+ install -m 755 src/.libs/*so* ${STAGING_LIBDIR}/
+}