aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libcwd/libcwd_0.99.47.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libcwd/libcwd_0.99.47.bb')
-rw-r--r--recipes/libcwd/libcwd_0.99.47.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/recipes/libcwd/libcwd_0.99.47.bb b/recipes/libcwd/libcwd_0.99.47.bb
new file mode 100644
index 0000000000..38453c89e5
--- /dev/null
+++ b/recipes/libcwd/libcwd_0.99.47.bb
@@ -0,0 +1,30 @@
+DESCRIPTION = "Libcwd is a thread-safe, full-featured debugging support library for C++ developers. \
+It includes ostream-based debug output with custom debug channels and devices, \
+powerful memory allocation debugging support, as well as run-time support for \
+printing source line number information and demangled type names."
+SECTION = "devel/libs"
+LICENSE = "QPL"
+HOMEPAGE = "http://libcwd.sourceforge.net"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libcwd/libcwd-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_configure() {
+ gnu-configize
+ oe_runconf
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+PARALLEL_MAKE = ""
+
+PACKAGES =+ "${PN}-config ${PN}-mt"
+FILES_${PN} = "${libdir}/libcwd.so*"
+FILES_${PN}-mt = "${libdir}/libcwd_r.so*"
+FILES_${PN}-config = "${datadir}"
+RRECOMMENDS_${PN} = "${PN}-config"
+RRECOMMENDS_${PN}-mt = "${PN}-config"