aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libdbi/libdbi_0.7.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libdbi/libdbi_0.7.2.bb')
-rw-r--r--recipes/libdbi/libdbi_0.7.2.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/libdbi/libdbi_0.7.2.bb b/recipes/libdbi/libdbi_0.7.2.bb
new file mode 100644
index 0000000000..8737890368
--- /dev/null
+++ b/recipes/libdbi/libdbi_0.7.2.bb
@@ -0,0 +1,22 @@
+# libdbi OE build file
+# Copyright (C) 2005, Koninklijke Philips Electronics NV. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "Database Independent Abstraction Layer for C"
+HOMEPAGE = "http://libdbi.sourceforge.net/"
+LICENSE = "LGPL"
+SECTION = "libs"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libdbi/libdbi-${PV}.tar.gz"
+
+inherit autotools
+
+do_stage () {
+ autotools_stage_includes
+ cd ./src/.libs/
+ oe_libinstall -so libdbi ${STAGING_LIBDIR}
+}
+
+do_configure () {
+ autotools_do_configure
+} \ No newline at end of file