aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libexif
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libexif')
-rw-r--r--recipes/libexif/libexif_0.5.12.bb16
-rw-r--r--recipes/libexif/libexif_0.6.13.bb19
-rw-r--r--recipes/libexif/libexif_0.6.16.bb18
-rw-r--r--recipes/libexif/libexif_0.6.17.bb18
-rw-r--r--recipes/libexif/libexif_0.6.9.bb19
5 files changed, 90 insertions, 0 deletions
diff --git a/recipes/libexif/libexif_0.5.12.bb b/recipes/libexif/libexif_0.5.12.bb
new file mode 100644
index 0000000000..94f3bee856
--- /dev/null
+++ b/recipes/libexif/libexif_0.5.12.bb
@@ -0,0 +1,16 @@
+SECTION = "libs"
+DESCRIPTION = "Library to read the extended image information (EXIF) from JPEG pictures"
+LICENSE = "LGPL"
+SRC_URI = "${SOURCEFORGE_MIRROR}/libexif/libexif-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_libinstall -a -so -C libexif libexif ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/libexif
+ for X in exif-byte-order.h exif-data.h exif-format.h exif-loader.h exif-tag.h exif-content.h exif-entry.h exif-ifd.h exif-result.h exif-utils.h
+ do
+ install -m 0644 ${S}/libexif/$X ${STAGING_INCDIR}/libexif/$X
+ done
+}
diff --git a/recipes/libexif/libexif_0.6.13.bb b/recipes/libexif/libexif_0.6.13.bb
new file mode 100644
index 0000000000..8382de84f5
--- /dev/null
+++ b/recipes/libexif/libexif_0.6.13.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Library to read the extended image information (EXIF) from JPEG pictures"
+HOMEPAGE = "http://sourceforge.net/projects/libexif"
+SECTION = "libs"
+LICENSE = "LGPL"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libexif/libexif-${PV}.tar.bz2"
+
+inherit autotools
+
+do_configure_append() {
+ sed -i s:doc\ binary:binary:g Makefile
+}
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/libexif/libexif_0.6.16.bb b/recipes/libexif/libexif_0.6.16.bb
new file mode 100644
index 0000000000..2f896352db
--- /dev/null
+++ b/recipes/libexif/libexif_0.6.16.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Library to read the extended image information (EXIF) from JPEG pictures"
+HOMEPAGE = "http://sourceforge.net/projects/libexif"
+SECTION = "libs"
+LICENSE = "LGPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libexif/libexif-${PV}.tar.bz2"
+
+inherit autotools
+
+do_configure_append() {
+ sed -i s:doc\ binary:binary:g Makefile
+}
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/libexif/libexif_0.6.17.bb b/recipes/libexif/libexif_0.6.17.bb
new file mode 100644
index 0000000000..2f896352db
--- /dev/null
+++ b/recipes/libexif/libexif_0.6.17.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Library to read the extended image information (EXIF) from JPEG pictures"
+HOMEPAGE = "http://sourceforge.net/projects/libexif"
+SECTION = "libs"
+LICENSE = "LGPL"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libexif/libexif-${PV}.tar.bz2"
+
+inherit autotools
+
+do_configure_append() {
+ sed -i s:doc\ binary:binary:g Makefile
+}
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
diff --git a/recipes/libexif/libexif_0.6.9.bb b/recipes/libexif/libexif_0.6.9.bb
new file mode 100644
index 0000000000..d255f5d862
--- /dev/null
+++ b/recipes/libexif/libexif_0.6.9.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Library to read the extended image information (EXIF) from JPEG pictures"
+HOMEPAGE = "http://sourceforge.net/projects/libexif"
+LICENSE = "LGPL"
+SECTION = "libs"
+PR = "r2"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libexif/libexif-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ oe_libinstall -a -so -C libexif libexif ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/libexif
+ for X in exif-byte-order.h exif-data.h exif-format.h exif-loader.h exif-tag.h exif-content.h exif-entry.h exif-ifd.h exif-result.h exif-utils.h exif-log.h exif-mnote-data.h _stdint.h
+ do
+ install -m 0644 ${S}/libexif/$X ${STAGING_INCDIR}/libexif/$X
+ done
+}