aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libgee/libgee_0.1.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libgee/libgee_0.1.4.bb')
-rw-r--r--recipes/libgee/libgee_0.1.4.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/libgee/libgee_0.1.4.bb b/recipes/libgee/libgee_0.1.4.bb
new file mode 100644
index 0000000000..8e3a90599a
--- /dev/null
+++ b/recipes/libgee/libgee_0.1.4.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "libgee is a collection library providing GObject-based interfaces \
+and classes for commonly used data structures."
+HOMEPAGE = "http://live.gnome.org/Libgee"
+SECTION = "libs"
+DEPENDS = "glib-2.0"
+LICENSE = "LGPL"
+
+SRC_URI = "ftp://ftp.gnome.org/pub/GNOME/sources/libgee/0.1/libgee-${PV}.tar.bz2 \
+ file://no-tests.patch;patch=1"
+
+inherit autotools pkgconfig
+
+do_stage() {
+ autotools_stage_all
+ install -d ${STAGING_DATADIR}/vala/vapi
+ install -m 0644 ${S}/gee/gee-1.0.vapi ${STAGING_DATADIR}/vala/vapi
+}
+
+FILES_${PN} += "${datadir}/vala"