summaryrefslogtreecommitdiffstats
path: root/recipes/libgpevtype/libgpevtype_0.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libgpevtype/libgpevtype_0.15.bb')
-rw-r--r--recipes/libgpevtype/libgpevtype_0.15.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/libgpevtype/libgpevtype_0.15.bb b/recipes/libgpevtype/libgpevtype_0.15.bb
new file mode 100644
index 0000000000..3f8af85beb
--- /dev/null
+++ b/recipes/libgpevtype/libgpevtype_0.15.bb
@@ -0,0 +1,24 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Data interchange library for GPE"
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+DEPENDS = "libmimedir libeventdb"
+PR = "r0"
+
+inherit pkgconfig gpe autotools
+
+SRC_URI = "${GPE_MIRROR}/${PN}-${PV}.tar.bz2"
+
+headers = "tag-db.h vcard.h vevent.h vtodo.h"
+
+
+do_stage () {
+ oe_libinstall -so libgpevtype ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/gpe
+ for h in ${headers}; do
+ install -m 0644 ${S}/gpe/$h ${STAGING_INCDIR}/gpe/${h}
+ done
+}
+
+