aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libgpg-error/libgpg-error_0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libgpg-error/libgpg-error_0.6.bb')
-rw-r--r--recipes/libgpg-error/libgpg-error_0.6.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/libgpg-error/libgpg-error_0.6.bb b/recipes/libgpg-error/libgpg-error_0.6.bb
new file mode 100644
index 0000000000..4929121167
--- /dev/null
+++ b/recipes/libgpg-error/libgpg-error_0.6.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "GPG-Error library"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL LGPL FDL"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/alpha/libgpg-error/libgpg-error-${PV}.tar.gz"
+
+inherit autotools binconfig
+
+do_stage() {
+ oe_libinstall -so -C src libgpg-error ${STAGING_LIBDIR}
+ install -d ${STAGING_BINDIR_CROSS}/
+ install -m 0755 src/gpg-error-config ${STAGING_BINDIR_CROSS}/
+
+ install -d ${STAGING_INCDIR}/
+ for X in gpg-error.h
+ do
+ install -m 0644 src/${X} ${STAGING_INCDIR}/${X}
+ done
+
+}