summaryrefslogtreecommitdiffstats
path: root/recipes/libhandoff
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libhandoff')
-rw-r--r--recipes/libhandoff/libhandoff_0.1.bb13
-rw-r--r--recipes/libhandoff/libhandoff_svn.bb18
2 files changed, 31 insertions, 0 deletions
diff --git a/recipes/libhandoff/libhandoff_0.1.bb b/recipes/libhandoff/libhandoff_0.1.bb
new file mode 100644
index 0000000000..bafbb9ec10
--- /dev/null
+++ b/recipes/libhandoff/libhandoff_0.1.bb
@@ -0,0 +1,13 @@
+LICENSE = "GPL"
+DESCRIPTION = "handoff library for GPE calendar"
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+DEPENDS = "glib-2.0"
+
+inherit pkgconfig gpe autotools
+
+GPE_TARBALL_SUFFIX = "bz2"
+
+do_stage () {
+ autotools_stage_all
+}
diff --git a/recipes/libhandoff/libhandoff_svn.bb b/recipes/libhandoff/libhandoff_svn.bb
new file mode 100644
index 0000000000..c545d9270e
--- /dev/null
+++ b/recipes/libhandoff/libhandoff_svn.bb
@@ -0,0 +1,18 @@
+LICENSE = "GPL"
+DESCRIPTION = "handoff library for GPE calendar"
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+DEPENDS = "glib-2.0"
+PV = "0.1+svn${SRCDATE}"
+PR = "r0"
+DEFAULT_PREFERENCE = "-1"
+
+inherit pkgconfig gpe autotools
+
+SRC_URI = "${GPE_SVN}"
+
+S = "${WORKDIR}/${PN}"
+
+do_stage () {
+autotools_stage_all
+}