summaryrefslogtreecommitdiffstats
path: root/recipes/libidn/libidn_1.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libidn/libidn_1.15.bb')
-rw-r--r--recipes/libidn/libidn_1.15.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/libidn/libidn_1.15.bb b/recipes/libidn/libidn_1.15.bb
new file mode 100644
index 0000000000..0a68a796c7
--- /dev/null
+++ b/recipes/libidn/libidn_1.15.bb
@@ -0,0 +1,19 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Implementation of the Stringprep, Punycode and IDNA specifications defined by the IETF Internationalized Domain Names (IDN) working group."
+SECTION = "libs"
+PRIORITY = "optional"
+PR = "r0"
+
+inherit pkgconfig autotools
+
+SRC_URI = "${GNU_MIRROR}/${PN}/${P}.tar.gz"
+
+EXTRA_OECONF = " --disable-tld"
+
+do_configure_prepend () {
+ autoreconf -f -i -s
+}
+
+do_stage () {
+ autotools_stage_all
+}