aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libnet/libnet-1.1.2.1
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libnet/libnet-1.1.2.1')
-rw-r--r--recipes/libnet/libnet-1.1.2.1/fix-endianess-test.patch36
-rw-r--r--recipes/libnet/libnet-1.1.2.1/new-autotools.patch20
-rw-r--r--recipes/libnet/libnet-1.1.2.1/support-uclibc.patch13
3 files changed, 69 insertions, 0 deletions
diff --git a/recipes/libnet/libnet-1.1.2.1/fix-endianess-test.patch b/recipes/libnet/libnet-1.1.2.1/fix-endianess-test.patch
new file mode 100644
index 0000000000..6d93e04f68
--- /dev/null
+++ b/recipes/libnet/libnet-1.1.2.1/fix-endianess-test.patch
@@ -0,0 +1,36 @@
+Use autoconf's endian check instead of the locally defined check
+so that we can determine the endianess without having to compile
+a program.
+
+Idea from http://www.security-lists.org/lists/libnet/2003/03/00001.html
+
+Also remove the old test from aclocal.m4.
+
+--- libnet/configure.in 2005/11/15 03:49:30 1.1
++++ libnet/configure.in 2005/11/15 03:50:29
+@@ -7,6 +7,7 @@
+ dnl Process this file with autoconf to produce a configure script.
+
+
++AC_PREREQ(2.52)
+ AC_INIT(src/libnet_build_ip.c)
+ LIBNET_VERSION=`cat VERSION`
+ AC_MSG_RESULT(beginning autoconfiguration process for libnet-$LIBNET_VERSION...)
+@@ -29,7 +30,16 @@
+ dnl And some custom things
+ dnl
+
+-AC_LIBNET_ENDIAN_CHECK
++AC_C_BIGENDIAN([
++ AC_DEFINE(LIBNET_BIG_ENDIAN)
++ ENDIANESS="LIBNET_BIG_ENDIAN"
++ LIBNET_CONFIG_DEFINES="$LIBNET_CONFIG_DEFINES -DLIBNET_BIG_ENDIAN"
++],[
++ AC_DEFINE(LIBNET_LIL_ENDIAN)
++ ENDIANESS="LIBNET_LIL_ENDIAN"
++ LIBNET_CONFIG_DEFINES="$LIBNET_CONFIG_DEFINES -DLIBNET_LIL_ENDIAN"
++], AC_MSG_WARN(cannot detect endianess. try setting ac_cv_c_bigendian to yes or no))
++
+ AC_LBL_UNALIGNED_ACCESS
+ dnl AC_LBL_LIBRARY_NET
+
diff --git a/recipes/libnet/libnet-1.1.2.1/new-autotools.patch b/recipes/libnet/libnet-1.1.2.1/new-autotools.patch
new file mode 100644
index 0000000000..064413e4ee
--- /dev/null
+++ b/recipes/libnet/libnet-1.1.2.1/new-autotools.patch
@@ -0,0 +1,20 @@
+Index: libnet/src/Makefile.am
+===================================================================
+--- libnet.orig/src/Makefile.am 2004-03-12 05:50:20.000000000 +1100
++++ libnet/src/Makefile.am 2007-08-11 16:41:09.000000000 +1000
+@@ -57,15 +57,5 @@
+ libnet_version.c \
+ libnet_write.c
+
+-EXTRA_libnet_a_SOURCES = libnet_link_bpf.c \
+- libnet_link_dlpi.c \
+- libnet_link_linux.c \
+- libnet_link_nit.c \
+- libnet_link_none.c \
+- libnet_link_pf.c \
+- libnet_link_snit.c \
+- libnet_link_snoop.c \
+- libnet_link_win32.c
+-
+ libnet_a_LIBADD = @LIBOBJS@
+
diff --git a/recipes/libnet/libnet-1.1.2.1/support-uclibc.patch b/recipes/libnet/libnet-1.1.2.1/support-uclibc.patch
new file mode 100644
index 0000000000..84d117c2e9
--- /dev/null
+++ b/recipes/libnet/libnet-1.1.2.1/support-uclibc.patch
@@ -0,0 +1,13 @@
+Add support for building with uclibc.
+
+--- libnet/config.sub 2005/11/16 12:34:11 1.1
++++ libnet/config.sub 2005/11/16 12:35:56
+@@ -117,7 +117,7 @@
+ # Here we must recognize all the valid KERNEL-OS combinations.
+ maybe_os=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\2/'`
+ case $maybe_os in
+- nto-qnx* | linux-gnu* | storm-chaos* | os2-emx* | windows32-*)
++ nto-qnx* | linux-gnu* | linux-uclibc* | storm-chaos* | os2-emx* | windows32-*)
+ os=-$maybe_os
+ basic_machine=`echo $1 | sed 's/^\(.*\)-\([^-]*-[^-]*\)$/\1/'`
+ ;;