aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libnfnetlink
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libnfnetlink')
-rw-r--r--recipes/libnfnetlink/libnfnetlink.inc15
-rw-r--r--recipes/libnfnetlink/libnfnetlink_0.0.30.bb20
-rw-r--r--recipes/libnfnetlink/libnfnetlink_0.0.39.bb26
3 files changed, 19 insertions, 42 deletions
diff --git a/recipes/libnfnetlink/libnfnetlink.inc b/recipes/libnfnetlink/libnfnetlink.inc
new file mode 100644
index 0000000000..2bb3d3dcfc
--- /dev/null
+++ b/recipes/libnfnetlink/libnfnetlink.inc
@@ -0,0 +1,15 @@
+DESCRIPTION = "libnfnetlink is the low-level library for netfilter related \
+kernel/userspace communication. It provides a generic messaging \
+infrastructure for in-kernel netfilter subsystems (such as nfnetlink_log, \
+nfnetlink_queue, nfnetlink_conntrack) and their respective users and/or \
+management tools in userspace."
+
+SECTION = "devel/libs"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.netfilter.org/projects/libnfnetlink/index.html"
+INC_PR = "r0"
+
+SRC_URI = "http://www.netfilter.org/projects/libnfnetlink/files/libnfnetlink-${PV}.tar.bz2"
+
+inherit autotools_stage pkgconfig
+
diff --git a/recipes/libnfnetlink/libnfnetlink_0.0.30.bb b/recipes/libnfnetlink/libnfnetlink_0.0.30.bb
index d3e3cabdc7..5d335a859a 100644
--- a/recipes/libnfnetlink/libnfnetlink_0.0.30.bb
+++ b/recipes/libnfnetlink/libnfnetlink_0.0.30.bb
@@ -1,25 +1,9 @@
-DESCRIPTION = "libnfnetlink is the low-level library for netfilter related \
-kernel/userspace communication. It provides a generic messaging \
-infrastructure for in-kernel netfilter subsystems (such as nfnetlink_log, \
-nfnetlink_queue, nfnetlink_conntrack) and their respective users and/or \
-management tools in userspace."
+include libnfnetlink.inc
-SECTION = "devel/libs"
-LICENSE = "GPL"
-HOMEPAGE = "http://www.netfilter.org/projects/libnfnetlink/index.html"
-PR = "r0"
-
-SRC_URI = "http://www.netfilter.org/projects/libnfnetlink/files/libnfnetlink-${PV}.tar.bz2"
-
-inherit autotools pkgconfig
+PR = "${INC_PR}.0"
do_configure() {
gnu-configize
libtoolize --force
oe_runconf
}
-
-do_stage() {
- autotools_stage_all
-}
-
diff --git a/recipes/libnfnetlink/libnfnetlink_0.0.39.bb b/recipes/libnfnetlink/libnfnetlink_0.0.39.bb
index a17a198961..23cbea904c 100644
--- a/recipes/libnfnetlink/libnfnetlink_0.0.39.bb
+++ b/recipes/libnfnetlink/libnfnetlink_0.0.39.bb
@@ -1,25 +1,3 @@
-DESCRIPTION = "libnfnetlink is the low-level library for netfilter related \
-kernel/userspace communication. It provides a generic messaging \
-infrastructure for in-kernel netfilter subsystems (such as nfnetlink_log, \
-nfnetlink_queue, nfnetlink_conntrack) and their respective users and/or \
-management tools in userspace."
-
-SECTION = "devel/libs"
-LICENSE = "GPL"
-HOMEPAGE = "http://www.netfilter.org/projects/libnfnetlink/index.html"
-PR = "r0"
-
-SRC_URI = "http://www.netfilter.org/projects/libnfnetlink/files/libnfnetlink-${PV}.tar.bz2"
-
-inherit autotools pkgconfig
-
-#do_configure() {
-# gnu-configize
-# libtoolize --force
-# oe_runconf
-#}
-
-do_stage() {
- autotools_stage_all
-}
+include libnfnetlink.inc
+PR = "${INC_PR}.0" \ No newline at end of file