aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libnl/libnl_1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libnl/libnl_1.1.bb')
-rw-r--r--recipes/libnl/libnl_1.1.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/libnl/libnl_1.1.bb b/recipes/libnl/libnl_1.1.bb
new file mode 100644
index 0000000000..dcca3c6e92
--- /dev/null
+++ b/recipes/libnl/libnl_1.1.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "libnl is a library for applications dealing with netlink sockets"
+SECTION = "libs/network"
+LICENSE = "LGPL"
+HOMEPAGE = "http://people.suug.ch/~tgr/libnl"
+PR = "r1"
+
+inherit autotools pkgconfig
+
+CFLAGS += '-DVLAN_FLAG_REORDER_HDR=1'
+
+SRC_URI = "\
+ http://people.suug.ch/~tgr/libnl/files/libnl-${PV}.tar.gz \
+ file://local-includes-and-avoid-wrong-ldflags.patch;patch=1 \
+ file://fix-includes.patch;patch=1 \
+"
+
+do_stage () {
+ autotools_stage_all prefix=${prefix}
+}