aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libogg/libtheora_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libogg/libtheora_1.0.bb')
-rw-r--r--recipes/libogg/libtheora_1.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/libogg/libtheora_1.0.bb b/recipes/libogg/libtheora_1.0.bb
new file mode 100644
index 0000000000..55d3e83beb
--- /dev/null
+++ b/recipes/libogg/libtheora_1.0.bb
@@ -0,0 +1,18 @@
+
+DEPENDS = "libogg libvorbis libsdl-x11"
+
+SRC_URI = "http://downloads.xiph.org/releases/theora/libtheora-${PV}.tar.bz2"
+
+inherit autotools lib_package
+
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i -e s:'-I/usr/include':-I${STAGING_INCDIR}:g
+}
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+do_stage() {
+ autotools_stage_all
+}
+
+