aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libogg
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libogg')
-rw-r--r--recipes/libogg/libtheora_1.0.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/recipes/libogg/libtheora_1.0.bb b/recipes/libogg/libtheora_1.0.bb
index 55d3e83beb..0d858cdbbe 100644
--- a/recipes/libogg/libtheora_1.0.bb
+++ b/recipes/libogg/libtheora_1.0.bb
@@ -1,18 +1,19 @@
-DEPENDS = "libogg libvorbis libsdl-x11"
+DEPENDS = "libogg libvorbis"
+
+PR = "r1"
SRC_URI = "http://downloads.xiph.org/releases/theora/libtheora-${PV}.tar.bz2"
inherit autotools lib_package
+EXTRA_OECONF = "--disable-examples"
+
+LEAD_SONAME = "libtheora.so.0"
do_configure_append() {
find ${S} -name Makefile | xargs sed -i -e s:'-I/usr/include':-I${STAGING_INCDIR}:g
}
AUTOTOOLS_STAGE_PKGCONFIG = "1"
-do_stage() {
- autotools_stage_all
-}
-