aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libpcre/libpcre-native_7.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libpcre/libpcre-native_7.6.bb')
-rw-r--r--recipes/libpcre/libpcre-native_7.6.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/recipes/libpcre/libpcre-native_7.6.bb b/recipes/libpcre/libpcre-native_7.6.bb
new file mode 100644
index 0000000000..20a4bdb978
--- /dev/null
+++ b/recipes/libpcre/libpcre-native_7.6.bb
@@ -0,0 +1,17 @@
+SECTION = "unknown"
+require libpcre_${PV}.bb
+inherit native
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libpcre-${PV}"
+
+# NOTE: multiple providers are available (libpcre, libpcre-native);
+# NOTE: consider defining PREFERRED_PROVIDER_pcre
+PROVIDES = ""
+
+do_compile () {
+ # The generation of dftables can lead to timestamp problems with ccache
+ # because the generated config.h seems newer. It is sufficient to ensure that the
+ # attempt to build dftables inside make will actually work (foo_FOR_BUILD is
+ # only used for this).
+ oe_runmake CC_FOR_BUILD="${BUILD_CC}" CFLAGS_FOR_BUILD="-DLINK_SIZE=2 -I${S}/include" LINK_FOR_BUILD="${BUILD_CC}"
+}
+