aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libschedule/libschedule_0.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libschedule/libschedule_0.14.bb')
-rw-r--r--recipes/libschedule/libschedule_0.14.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/libschedule/libschedule_0.14.bb b/recipes/libschedule/libschedule_0.14.bb
new file mode 100644
index 0000000000..11729b095e
--- /dev/null
+++ b/recipes/libschedule/libschedule_0.14.bb
@@ -0,0 +1,24 @@
+LICENSE = "LGPL"
+PR = "r1"
+DESCRIPTION = "RTC alarm handling library for GPE"
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+DEPENDS = "glib-2.0"
+
+inherit pkgconfig gpe
+
+headers = "schedule.h"
+
+do_stage () {
+ oe_libinstall -so libschedule ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/gpe
+ for h in ${headers}; do
+ install -m 0644 ${S}/gpe/$h ${STAGING_INCDIR}/gpe/$h
+ done
+}
+
+do_install () {
+ gpe_do_install
+ oe_runmake PREFIX=${prefix} DESTDIR=${D} install-devel
+}