aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libsdl/libsdl-gfx_2.0.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libsdl/libsdl-gfx_2.0.11.bb')
-rw-r--r--recipes/libsdl/libsdl-gfx_2.0.11.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/libsdl/libsdl-gfx_2.0.11.bb b/recipes/libsdl/libsdl-gfx_2.0.11.bb
new file mode 100644
index 0000000000..712675771a
--- /dev/null
+++ b/recipes/libsdl/libsdl-gfx_2.0.11.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Simple DirectMedia Layer graphic primitives library."
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "zlib libpng jpeg virtual/libsdl"
+LICENSE = "LGPL"
+
+SRC_URI = "http://www.ferzkopp.net/~aschiffler/Software/SDL_gfx-2.0/SDL_gfx-${PV}.tar.gz"
+S = "${WORKDIR}/SDL_gfx-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-mmx"
+
+do_stage() {
+ oe_libinstall -so libSDL_gfx ${STAGING_LIBDIR}
+ install -m 0644 *.h ${STAGING_INCDIR}/SDL/
+}
+