aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libsdl/libsdl-mixer_1.2.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libsdl/libsdl-mixer_1.2.6.bb')
-rw-r--r--recipes/libsdl/libsdl-mixer_1.2.6.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/libsdl/libsdl-mixer_1.2.6.bb b/recipes/libsdl/libsdl-mixer_1.2.6.bb
new file mode 100644
index 0000000000..0c29a3c625
--- /dev/null
+++ b/recipes/libsdl/libsdl-mixer_1.2.6.bb
@@ -0,0 +1,24 @@
+DESCRIPTION = "Simple DirectMedia Layer mixer library."
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "virtual/libsdl libmikmod libvorbis"
+LICENSE = "LGPL"
+PR = "r3"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_mixer/release/SDL_mixer-${PV}.tar.gz"
+S = "${WORKDIR}/SDL_mixer-${PV}"
+
+export SDL_CONFIG = "${STAGING_BINDIR_CROSS}/sdl-config"
+
+inherit autotools
+
+EXTRA_OECONF = "--disable-music-mp3"
+# although we build smpeg... need to find out how
+# to deal with optional dependencies
+
+do_stage() {
+ oe_libinstall -so libSDL_mixer ${STAGING_LIBDIR}
+ ln -sf libSDL_mixer.so ${STAGING_LIBDIR}/libSDL_mixer-1.2.so
+ install -m 0644 SDL_mixer.h ${STAGING_INCDIR}/SDL/SDL_mixer.h
+}
+