aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libsdl/libsdl-net_1.2.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libsdl/libsdl-net_1.2.7.bb')
-rw-r--r--recipes/libsdl/libsdl-net_1.2.7.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/recipes/libsdl/libsdl-net_1.2.7.bb b/recipes/libsdl/libsdl-net_1.2.7.bb
new file mode 100644
index 0000000000..8cbea5bd01
--- /dev/null
+++ b/recipes/libsdl/libsdl-net_1.2.7.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Simple DirectMedia Layer networking library."
+SECTION = "libs/network"
+PRIORITY = "optional"
+DEPENDS = "virtual/libsdl"
+LICENSE = "LGPL"
+PR = "r1"
+
+SRC_URI = "http://www.libsdl.org/projects/SDL_net/release/SDL_net-${PV}.tar.gz \
+ file://libtool2.patch;patch=1 \
+ "
+
+S = "${WORKDIR}/SDL_net-${PV}"
+
+inherit autotools
+
+EXTRA_OECONF += "SDL_CONFIG=${STAGING_BINDIR_CROSS}/sdl-config"
+
+do_stage() {
+ autotools_stage_all
+}
+