aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libssh/libssh_0.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libssh/libssh_0.11.bb')
-rw-r--r--recipes/libssh/libssh_0.11.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/libssh/libssh_0.11.bb b/recipes/libssh/libssh_0.11.bb
new file mode 100644
index 0000000000..833567ebb0
--- /dev/null
+++ b/recipes/libssh/libssh_0.11.bb
@@ -0,0 +1,35 @@
+SECTION = "libs"
+DESCRIPTION = "The SSH library is a C library to authenticate in a \
+simple manner to one or more SSH servers. The goal of this project \
+is to provide a library much simpler to use than OpenSSHs one. It \
+includes SFTP support, and a sample SSH client is provided."
+DEPENDS = "openssl"
+LICENSE = "LGPL"
+
+DEFAULT_PREFERENCE="-1"
+
+SRC_URI = "http://www.0xbadc0de.be/libssh/libssh-${PV}.tgz"
+
+inherit autotools
+
+EXTRA_OECONF = "--cache-file=${S}/config.cache"
+
+do_stage () {
+ set -x
+ install -d ${STAGING_INCDIR}/libssh
+ for i in crypto.h libssh.h sftp.h ssh2.h; do
+ install -m 0644 ${S}/include/libssh/$i ${STAGING_INCDIR}/libssh/
+ done
+ oe_libinstall -so -C libssh libssh ${STAGING_LIBDIR}
+}
+
+do_install () {
+ oe_runmake "prefix=${D}${prefix}" \
+ "exec_prefix=${D}${exec_prefix}" \
+ "bindir=${D}${bindir}" \
+ "incldir=${D}${includedir}" \
+ "infodir=${D}${infodir}" \
+ "mandir=${D}${mandir}/man1" \
+ "libdir=${D}${libdir}" \
+ install
+}