aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libtododb/libtododb_0.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libtododb/libtododb_0.10.bb')
-rw-r--r--recipes/libtododb/libtododb_0.10.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/recipes/libtododb/libtododb_0.10.bb b/recipes/libtododb/libtododb_0.10.bb
new file mode 100644
index 0000000000..bb6f95a5b1
--- /dev/null
+++ b/recipes/libtododb/libtododb_0.10.bb
@@ -0,0 +1,24 @@
+LICENSE = "LGPL"
+DESCRIPTION = "Database access for GPE to-do list"
+SECTION = "gpe/libs"
+PRIORITY = "optional"
+DEPENDS = "libgpewidget libgpepimc sqlite"
+
+GPE_TARBALL_SUFFIX = "bz2"
+inherit pkgconfig gpe autotools
+
+headers = "todo-db.h"
+
+do_stage () {
+ oe_libinstall -so libtododb ${STAGING_LIBDIR}
+
+ mkdir -p ${STAGING_INCDIR}/gpe
+ for h in ${headers}; do
+ install -m 0644 ${S}/gpe/$h ${STAGING_INCDIR}/gpe/$h
+ done
+}
+
+do_install () {
+ gpe_do_install
+# oe_runmake PREFIX=${prefix} DESTDIR=${D} install-devel
+}