summaryrefslogtreecommitdiffstats
path: root/recipes/libwiimote
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libwiimote')
-rw-r--r--recipes/libwiimote/libwiimote_0.4.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/recipes/libwiimote/libwiimote_0.4.bb b/recipes/libwiimote/libwiimote_0.4.bb
new file mode 100644
index 0000000000..ea794940dd
--- /dev/null
+++ b/recipes/libwiimote/libwiimote_0.4.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "wiimote access library"
+LICENSE = "GPLv2"
+HOMEPAGE = "http://sourceforge.net/projects/libwiimote/"
+
+PR = "r1"
+
+inherit autotools
+
+DEPENDS = "bluez-libs"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/libwiimote/libwiimote-${PV}.tgz"
+
+do_configure_append() {
+ find ${S} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
+ find ${S} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
+}
+
+