aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libxcomp/files/use-const-char-pointer.patch
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libxcomp/files/use-const-char-pointer.patch')
-rw-r--r--recipes/libxcomp/files/use-const-char-pointer.patch35
1 files changed, 35 insertions, 0 deletions
diff --git a/recipes/libxcomp/files/use-const-char-pointer.patch b/recipes/libxcomp/files/use-const-char-pointer.patch
new file mode 100644
index 0000000000..735e2e3a73
--- /dev/null
+++ b/recipes/libxcomp/files/use-const-char-pointer.patch
@@ -0,0 +1,35 @@
+Index: nxcomp/Loop.cpp
+===================================================================
+--- nxcomp.orig/Loop.cpp
++++ nxcomp/Loop.cpp
+@@ -10979,7 +10979,7 @@ int ParsePackOption(const char *opt)
+ packMethod == PACK_LOSSLESS ||
+ packMethod == PACK_ADAPTIVE)
+ {
+- char *dash = rindex(opt, '-');
++ const char *dash = rindex(opt, '-');
+
+ if (dash != NULL && strlen(dash) == 2 &&
+ *(dash + 1) >= '0' && *(dash + 1) <= '9')
+Index: nxcomp/configure.in
+===================================================================
+--- nxcomp.orig/configure.in
++++ nxcomp/configure.in
+@@ -68,7 +68,7 @@ case "${gcc_version}" in
+ ;;
+ esac
+
+-AC_MSG_CHECKING([whether compiler accepts -Wmissing-declarations and -Wnested-externs])
++AC_MSG_CHECKING([whether compiler accepts -Wmissing-declarations])
+ gcc_version=`${CC} --version | grep 'gcc (GCC) [[3-4]].' | head -n 1`
+ case "${gcc_version}" in
+ gcc*)
+@@ -77,7 +77,7 @@ case "${gcc_version}" in
+
+ *)
+ AC_MSG_RESULT([yes])
+- CXXFLAGS="$CXXFLAGS -Wmissing-declarations -Wnested-externs"
++ CXXFLAGS="$CXXFLAGS -Wmissing-declarations"
+ ;;
+ esac
+