aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/libxslt/libxslt_1.1.21.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/libxslt/libxslt_1.1.21.bb')
-rw-r--r--recipes/libxslt/libxslt_1.1.21.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/libxslt/libxslt_1.1.21.bb b/recipes/libxslt/libxslt_1.1.21.bb
new file mode 100644
index 0000000000..282918e83e
--- /dev/null
+++ b/recipes/libxslt/libxslt_1.1.21.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "GNOME XSLT library"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "libxml2 (>=2.6.27)"
+LICENSE = "MIT"
+PR = "r2"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxslt-${PV}.tar.gz"
+S = "${WORKDIR}/libxslt-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--without-python --without-debug --without-mem-debug --without-crypto"
+
+do_stage () {
+ autotools_stage_all
+}
+
+PACKAGES = "${PN}-dbg ${PN}-dev ${PN}-utils ${PN} ${PN}-doc ${PN}-locale"
+
+FILES_${PN}-dev += "${bindir}/xslt-config"
+FILES_${PN}-utils += "${bindir}"