aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-bug_2.6.27.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-bug_2.6.27.2.bb')
-rw-r--r--recipes/linux/linux-bug_2.6.27.2.bb13
1 files changed, 10 insertions, 3 deletions
diff --git a/recipes/linux/linux-bug_2.6.27.2.bb b/recipes/linux/linux-bug_2.6.27.2.bb
index b5899a7235..8c83f9ab7f 100644
--- a/recipes/linux/linux-bug_2.6.27.2.bb
+++ b/recipes/linux/linux-bug_2.6.27.2.bb
@@ -2,12 +2,12 @@ DESCRIPTION = "Linux kernel for bug"
PV_append = "+svnr${SRCREV}"
KV = "2.6.27.2"
-PR = "r28"
+PR = "r29"
COMPATIBLE_MACHINE = "bug"
SVN_PRJ = "bug-linux-${KV}"
-SRCREV = "10017"
+SRCREV = "10199"
SRC_URI = "svn://svn.buglabs.net/bug/branches/R1.4/qa;module=${SVN_PRJ};proto=svn \
file://defconfig \
@@ -21,10 +21,17 @@ UBOOT_ENTRYPOINT = "0x80008000"
require linux.inc
do_install_append() {
-# install -m 0644 arch/${ARCH}/boot/uImage ${D}/${KERNEL_IMAGEDEST}/uImage-${KERNEL_VERSION}
cd ${D}/${KERNEL_IMAGEDEST} && ln -sf uImage-${KERNEL_VERSION} uImage
}
+do_stage_append() {
+ cp -fR arch/arm/include/asm/* ${STAGING_KERNEL_DIR}/include/asm/
+ if [ ! -e ${STAGING_KERNEL_DIR}/include/mach ]; then
+ mkdir ${STAGING_KERNEL_DIR}/include/mach
+ fi
+ cp -fR arch/arm/plat-mxc/include/mach/* ${STAGING_KERNEL_DIR}/include/mach/
+}
+
FILESDIR = "${WORKDIR}"
FILES_kernel-image += "${KERNEL_IMAGEDEST}/uImage*"