aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-h1940_2.6.14-h1940.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-h1940_2.6.14-h1940.bb')
-rw-r--r--recipes/linux/linux-h1940_2.6.14-h1940.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/linux/linux-h1940_2.6.14-h1940.bb b/recipes/linux/linux-h1940_2.6.14-h1940.bb
new file mode 100644
index 0000000000..5a657eb0b5
--- /dev/null
+++ b/recipes/linux/linux-h1940_2.6.14-h1940.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Linux kernel for h1940 devices."
+SECTION = "kernel"
+LICENSE = "GPL"
+
+COMPATIBLE_HOST = "arm.*-linux"
+COMPATIBLE_MACHINE = "h1940"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.14.tar.bz2 \
+ http://rtpnet.nerim.net/ipaq/patches/2.6.14-3/v2.6.14-gitcurrent.patch;patch=1 \
+ http://rtpnet.nerim.net/ipaq/patches/2.6.14-3/full.patch;patch=1 \
+ file://defconfig"
+
+S = "${WORKDIR}/linux-2.6.14"
+
+inherit kernel
+
+do_configure() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ yes '' | oe_runmake oldconfig
+}