aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-h6300-omap1_2.6.12-rc5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-h6300-omap1_2.6.12-rc5.bb')
-rw-r--r--recipes/linux/linux-h6300-omap1_2.6.12-rc5.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/recipes/linux/linux-h6300-omap1_2.6.12-rc5.bb b/recipes/linux/linux-h6300-omap1_2.6.12-rc5.bb
new file mode 100644
index 0000000000..58e85781a3
--- /dev/null
+++ b/recipes/linux/linux-h6300-omap1_2.6.12-rc5.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Linux kernel for h6300 devices."
+SECTION = "kernel"
+LICENSE = "GPL"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/testing/linux-2.6.12-rc5.tar.bz2 \
+ http://www.muru.com/linux/omap/patches/patch-2.6.12-rc5-omap2.bz2;patch=1 \
+ file://h6300_omap1_2612rc5.patch;patch=1 \
+ file://defconfig"
+
+S = "${WORKDIR}/linux-2.6.12-rc5"
+
+inherit kernel
+
+COMPATIBLE_MACHINE = "h6300"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+ oe_runmake oldconfig
+}