aboutsummaryrefslogtreecommitdiffstats
path: root/recipes/linux/linux-jlime-jornada6xx_2.6.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'recipes/linux/linux-jlime-jornada6xx_2.6.11.bb')
-rw-r--r--recipes/linux/linux-jlime-jornada6xx_2.6.11.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/recipes/linux/linux-jlime-jornada6xx_2.6.11.bb b/recipes/linux/linux-jlime-jornada6xx_2.6.11.bb
new file mode 100644
index 0000000000..654b02788c
--- /dev/null
+++ b/recipes/linux/linux-jlime-jornada6xx_2.6.11.bb
@@ -0,0 +1,22 @@
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for Hitachi SH3 based Jornada 6xx"
+LICENSE = "GPL"
+PR = "r0"
+
+
+COMPATIBLE_HOST = "sh.*-linux"
+COMPATIBLE_MACHINE = 'jornada6xx'
+
+SRC_URI = "http://www.jlime.com/downloads/releases/shrek/kernels/6xx/sources/linuxsh-snapshot-050320-jlimepatched-3.tar.bz2 \
+ file://defconfig_jlime"
+
+S = "${WORKDIR}/linux-${PV}"
+
+inherit kernel
+
+ARCH = "sh"
+FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig_jlime ${S}/.config
+}